Overlay Tool User's Guide

Introduction
TASK:  Install Map & Overlay Tools for PowerPoint 97
TASK:  Create Unit Symbols 

TASK:  Create Obstacles and Control Measures
TASK:  Create Witness Marks
TASK:  Save and Restore Views of the Overlay
TASK:  View the Overlay Contents
TASK:  Move an Overlay Symbol
TASK: Extract Overlay Symbology to an ASCII Export File
Annex A - Installation Procedure from Diskette.
Annex B - Overlay Extract File Format
Introduction

This tool was developed to simply the task of creating military overlays in PowerPoint.  It was designed to be used with electronic maps such as those developed under the TREDS effort as U.S.A. STRICOM.  The tool was written in Visual Basic and provides custom toolbars, menus, options, and screens to access its flexible overlay development tools.

The tool may be installed from diskette or by downloading a self-extracting executable from the TREDS Web pages at www.stricom.army.mil/PRODUCTS/TREDS .
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TASK:  Install Map & Overlay Tools for PowerPoint 97

PROCEDURE:

1) Run PowerPoint

2) Open the file "Overlay.ppt" located in the "TREDS\Overlay" directory.

a) If the following dialog appears, 
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Uncheck the "Always ask before opening documents with macros" and click on the "Enable Macros" button.  PowerPoint will then prompt for verification as follows:
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Click on "Yes", to finish opening the "Overlay" presentation.

b) The following screen will appear:
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This PowerPoint file contains Visual Basic Macros which are used to create toolbars and associated functinality for developing overlay symbology in PowerPoint.

3) Press the Alt+ F8 keys simutaneously, the following dialog screen will appear:
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4) Run the "Install_Overaly_Tools" macro.

a) To do this, scroll down the list and click on the "Install_Overlay_Tools" macro, as shown in the following figure:
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b) Then, click on the "Run" button.

c) PowerPoint will then save the Visual Basic macros to a PowerPoint addin named "Overlay.ppa".  

d) The addin will then be initialize and display the following splash screen in PowerPoint:


[image: image7.png]RCI/STRICOM

Overlay Tool

For Microsoft® PowerPoint®

PM CATT LS. Army STRICOM
12249 Science Drive

Orlando, FL 32826

POC: Dr. Mona Crissey (407) 3543639
aisseym@stricom. army. il





e) Next, the toolbars will be automatically generated as show in the following screen:
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The following table summarizes the toolbars which should have been created.

Toolbar Name
Description & Function

Overlay Tools
Obstacles and Control Measures

TREDS Tools
Standard Shape and Control Drawing Tools

Vehicles
Vehicle/Entity Level Tools

Map Tools
Tools for using and Creating TREDS Maps

Unit Echelons 
Tools for Creating Unit Echelon Symbols

Unit Roles
Tools for Creating Unit Role Symbols

f) Click on "OK" in response to the displayed message, and select the "Close" option under the "File menu to complete the installation process.

5) Installation is now complete.  Doc your tool bars on the top, bottom, or sides of the PowerPoint workspace as desired, and Exit PowerPoint or open a file to begin creating overlays.

TASK:  Create Unit Symbols 

SEE ALSO:

TASK:  Create Obstacles and Control Measures
TASK:  Create Witness Marks
PROCEDURE:

1) Click on the Rectangle tool, for BLUFOR units, or the Diamond tool, for OPFOR units, found on the "TREDS Tools" toolbar, and draw the appropriate shape.  See the following figure for an example:
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2) With the rectangle or diamond selected, click on the desired unit echelons and/or roles.  The unit symbol will be created replacing the original symbol as shown in the following figure:
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3) Give unit a designation (name) by clicking on each "?" to the right and left of the symbol and replace the question mark with  the appropriate designations.  For example:
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In the figure to the left a designation of A/2/33/AR was added to the above unit symbol:

NOTE: Unit echelons my also be used to identify other objects such as phase lines (Freeform tool), battle positions, or any other shape which can be produced in PowerPoint.  See the following examples:
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Draw and Oval

Click on the Oval to Battle Position tool (Overaly Tools)

Click on the Fortification tool (Overlay Tools)

Click on the Platoon Echelon tool
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Draw a Diamond

Click on the Platoon Echelon tool

Click on the Artillery Role tool

Click on the Unit Color to Red tool

NOTE:  Color and line thickness for each overlay shape or symbol may be changed using the following tools:
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Change visible colors to Blue (BLUFOR)
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Change Visible colors to Red (OPFOR)

[image: image28.bmp]
Change Visible lines to Double Lines

NOTE: Overlay Symbology should not be copied and pasted from.  When a shape is pasted onto a PowerPoint slide, PowerPoint assigns it's own name to the object.  Therefore, if a valid TREDS shape is copied, and then subsequently pasted, the overlay tool will no longer be able to identify it by name.

TASK:  Create Obstacles and Control Measures

SEE ALSO:

TASK:  Create Unit Symbols
TASK:  Create Witness Marks
PROCEDURE:

1) Draw a rectangle, oval, line, or freefrom as identified in the tip for the desired tool to be used.  

NOTE: To view the tip, move the mouse over the tool button and wait for the tip to be displayed.  For example, the tip for an Antitank mine field would be displayed as: 
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This tip shows that a mine field may be create from a line or rectangle shape.  

2) After drawing the appropriate shape, click on the desired tool or combination of tools to create your symbol.  When using lines for creating symbols, the height of the symbol is defined by the Font size displayed in the popup menu of the TREDS Tools toolbar.

Here are some examples of obstacle symbols which can be created using the Overlay Tools toolbar:
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Draw a rectangle, click on the Antitank minefield tool

Click on the Antitank ditch tool
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  Draw a line or rectangle

  Click the FrontLines tool
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Draw a line or rectangle

Click on the Wire tool

 Draw a line or rectangle

    Click on the Fortification tool

Here are some examples of control measure symbols which can be created using the Overlay Tools toolbar:


Draw rectangle to encompass each arrow head

Select each rectangle and Click on the Avenue of Approach tool

Select the larger rectangle and click on the double lines tool

Select the Arc tool and connect the arrow heads

Select both arrow heads and associated arcs, then click on the Group tool.

Create the unit symbol.

Draw a rectangle

Click on the Checkpoint tool


Draw a rectangle.

Click on the Target Reference Point tool

NOTE:  Color and line thickness for each overlay shape or symbol may be changed using the following tools:

Increase Line Thickness
Decrease Line Thickness


Change visible colors to Blue (BLUFOR)


Change Visible colors to Red (OPFOR)


Change Visible lines to Double Lines

NOTE: Overlay Symbology should not be copied and pasted from.  When a shape is pasted onto a PowerPoint slide, PowerPoint assigns it's own name to the object.  Therefore, if a valid TREDS shape is copied, and then subsequently pasted, the overlay tool will no longer be able to identify it by name.

TASK:  Create Witness Marks

SEE ALSO:

TASK:  Create Unit Symbols
TASK:  Create Obstacles and Control Measures
TASK:  View the Overlay Contents
TASK: Extract Overlay Symbology to an ASCII Export File
PROCEDURE:
1) Apply a TREDS map to your overlay file by:

a) Select the Apply Design option of the Format menu.  The following dialog will appear:

b) Set the "Files of Type" popup to "All PowerPoint Files".

c) Locate and select a TREDS Map .
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d) Click on the Apply button.

e) The map should appear as a background to your overlay slide.

2) Draw a rectangle over a selected grid square
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3) Click on the Witness Mark tool.  The rectangle will be converted to a Witness mark as shown in the following figure:
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4) Enter the Map Designation and grid coordinates by replacing the displayed question marks
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5) Repeat for a second Witness Mark.
NOTE: Do Not copy and paste the witness mark, as that will break the link which defines this shape as a Witness Mark to the Overaly utility.  This link is used enable the give the overlay tool Grid Coordinate awarness of all features drawn on the overlay.
6) Now that the Witness Marks have been created, the Overlay tool will now be aware of the grid locations for each overlay symbol.  See TASK:  View the Overlay Contents, and  TASK:  Move an Overlay Symbol for more information on how Gird Coordinate data impacts on the Overlay tool.

TASK:  View the Overlay Contents

PROCEDURE:

1) Open an overlay, created with the PowerPoint Overlay Tools, in PowerPoint.  For example, the following figure depicts a STRUCCTT overlay developed for TREDS.
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2) From the "View" menu, select "Overlay Contents".  The following dialog box will appear:
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3) Any displayed symbol or shape may be manipulated as follows:

· Selecting an item in the list, results in that shape being selected on the overlay.

· Clicking on the "Delete" button, results in that shape or symbol being deleted from the overlay.

· Clicking on the "Move" button will allow the user to specify new grid coordinates to which the shape is to be moved.

· Clicking on the "Zoom To" button, results in PowerPoint zooming into the selected shape, and the closing the dialog box.  This function is equivalent to selecting an object and clicking on the Zoom to Selection tool.

· Clicking on the "Close" button, results in the closing of the dialog box.

NOTE: For more information on the "Move" function see TASK: Move and Overlay Symbol.

TASK:  Save and Restore Views of the Overlay

PROCEDURE: 


1) To save a particular zoom:

a) Select the shape or symbol of interest.

b) Set the appropriate zoom

c) Select the "Save View" option under the "Window" menu. 

2) This will add a new option to the Window menu.  Up to eight views may be saved to the menu.  In the example to the right, a view for a Target Reference Point (TRP) was saved at a zoom of 400%.

3) To restore the view, simply select the view (number) of choice from the window menu.

4) To clear previously set views, select the "Release Views" option from the "Window" menu.

NOTE:  If an item associated with a view is modified or deleted, the view cannot be restored.

TASK:  Move an Overlay Symbol

SEE ALSO:

TASK:  View the Overlay Contents
PROCEDURE: 

1) Make sure the appropriate Witness Marks have been created and are linked to the Overlay Tool.  To check this perform the TASK: View the Overlay Contents, and verify that two witness marks appear in the list.

2) Select the shape or symbol to be moved.

3) From the Overlay Contents dialog box, click on the "Move" button,

Or

4) Select the "Move Overlay Item" option from the "Edit" menu.

5) The following dialog box will appear:

6) The three fields of data represent a 10 digit grid coordinate for the shape.  In this case a Target Reference Point.

a) To move the shape, modify the three fields of data and click on "Move" button.  Note, the shape will immediately move to it's new position.

b) The "Reset" button may be used to restore the shape's original position.

c) The "Cancel" button will reset the shape's position, and close the dialog box.

d) The "Close" button will close the dialog box leaving the shape in the last position specified by the 10 digit grid position.

TASK: Extract Overlay Symbology to an ASCII Export File

SEE ALSO:

TASK:  Create Unit Symbols
TASK:  Create Witness Marks
TASK:  Create Obstacles and Control Measures
PROCEDURE: 

1) Open an overlay, created with the PowerPoint Overlay Tools.  For example, the following figure depicts a STRUCCTT overlay developed for TREDS.
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2) Make sure at least two valid witness marks have been created on the Overlay.  To verify this view the overlay's contents by performing TASK: View Overlay Contents.

3) If the contents of the overlay list two or more witness marks, and the grid locations of each unit, obstacle, and control measure look good:

a) Select the "Save as TREDS Extract" option from the "File" menu.

b) The tool will extract the contents of the open overlay file to a file of the same name with and extension of ".txt".

c) The tool will the display the following prompt:
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4) If a problem is identified with the grid locations, you may need to delete and recreate the witness marks.  

NOTE: Overlay Symbology should not be copied and pasted from.  When a shape is pasted onto a PowerPoint slide, PowerPoint assigns it's own name to the object.  Therefore, if a valid TREDS shape is copied, and then subsequently pasted, the overlay tool will no longer be able to identify it by name.

5) Answering "Yes" to the prompt will result in the file being opened and displayed in the windows Notepad.  See the example in the following figure:
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[File: C:\My Documents\Presentations\Overlay\PLFUNT3

start Hap;
Map_besignation = “NJ*
PointsToGrids - 3.352253E-02
Grid_Xoffset - 43.98271

Grid_vOffset = 83.98297
End Hap;

Begin BLUFOR Units;
Begin Iten;
Nane ="“tredsUnit AR PLT 443"
Designation
Center Point
End Iten;
End BLUFOR Units;

Begin OPFOR Units;
[End OPFOR Units;

Begin Obstacles;
Begin Iten;





For more information on the structure of this file see: TREDS Overlay Extract Formats Defined.
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